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Introduction  
Tile Builder is a Photoshop-compatible plug-in for creation seamless patterns from images using 
symmetry rules. This plug-in will be useful for web designers, artists, photo and computer 
graphics enthusiasts. It allows you create fantastic attractive seamless patterns by one touch. 

Tile Builder can work as with commercial software like Adobe Photoshop, Adobe Photoshop 
Elements, Corel (Jasc) Paint Shop Pro, Microsoft Digital Image Suite as free like software 
IrfanView, XnView.  There is Windows version only. 

Tile Builder has unique flexibility and power: you can move, rotate and bend target shape in order 
to match desirable motif for you seamless pattern. You can adjust pattern size and edge 
overlapping for creation smooth transition between shape sides. You can see result of flood filling 
using generated pattern in preview window.  

Also, you can save generated rectangular seamless pattern as BMP, JPEG or PNG graphic file 
for using anywhere.   

 

Features at glance 
• You can adjust tile size and bend side to match image motif  

• You can blend tile to each other  

• Separate tile preview window  

• You can save seamless tile to PNG, BMP, JPG format for use tile anywhere  

• 16-bit mode support  

• Action (script) feature 

• Presets feature 

 

System Requirements 
Computer  Pentium 400MHz 

Operation System  Win98, Win200, Win2003, Win XP, Win NT3, Win NT4 

Hard Drive  you must have free space about 3 Mb 

RAM  64Mb 

Miscellaneous   mouse or other pointing device  

  You must have suitable graphic host software (see below) 

Registering ImageSkill Tile Builder 
You can order full version of this plug-in via ShareIt and RegNow services (the latter accept 
PayPal). If you buy Tile Builder through these services you receive user name and unlock key. 
Please, enter their carefully without additional blanks. Use copy-paste method. 
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If you have any trouble with unlock key, write sales@imageskill.com

Registered users receive our email newsletter containing information about new product releases 
and updates, free downloads, articles, tips, and special offers. 

Just now, we upgrade our products for registered customer free of charge. 

Getting Technical Support 
If you have any trouble, questions, feature requests or notes, you can get help in one of the 
following ways: 

E-Mail: support@imageskill.com

Web site: http://forum.imageskill.com
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Getting Started 

Pattern, Frieze and Rosette  
What does it mean “seamless tile or “pattern”? It is a color image (grayscale image is usually 
named as “texture”), that left side pixels match to right side pixels and upper side corresponds to 
bottom side. Using replication (or Flood Filling) of these images you can get image having any 
size you need without visible seam. 

 For example left image below is a tile (or pattern), because left side matches to right side (blue 
lines) and bottom side matches to upper side (red line). Right image is a result of flood filling. 

 

 

 

Tile Builder creates seamless tiles from images using symmetry rules (transition, rotation, 
reflection and glide reflection). It solves “tessellation” task - filling 2D plane by some motif without 
gaps and overlapping.  It does not deform source image, only shifts (transition), rotates by 60, 
120, 90, 180 degree step and reflects (mirrors) it. 

 

 
 

Translation 

 
 

Reflection (Mirror) 
 

Rotation by 90 degree 
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There are only 17 tiling methods for plane (there is a strongly mathematical proof; you can see 
more detail in The Discontinuous Groups of Rotation and Translation in the Plane  or SYMMETRY 
AND ORNAMENT by  Slavik V. Jablan ), 7 types for frieze and 10 for rosette. 

 

Frieze is a pattern where only two sides match to each other (for example left and right or up and 
bottom). In order to receive ornament form frieze use replication in only one direction. 

 

 

 
 

 

 

 

 
 

 

 

 

 

Rosette is a figure created by rotation around one point and reflection.  
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Installing and uninstalling 
Run setup file. Installer can detect the most popular graphics editors automatically. Choose one of 
them from list. If you want to install plug-in in other folder, select item "Other path" and set path. 
In this case you must set "Plug-ins path" of your graphic host to setup folder. 

 

Plug-in’s installer automatically detects the following graphic host applications: 

• Adobe Photoshop 7, CS, CS2, CS3 

• Adobe Photoshop Elements 2, 3, 4, 5 

• Jasc Paint Shop Pro 7, 8, 9 

• Corel Paint Shop Pro (Photo) X, X1 

• Corel Photo Paint 11,12 

• Xara Xtreme 

• Microsoft Digital Image Suite 2006 

• Macromedia Fireworks 2004, 8 

• Ulead PhotoImpact 8,9,10,11,12 

 

Plug-in can work under the following graphics host properly  

• XnView 1.8 and older 

• IrfanView 

• Corel Painter  

• Adobe Illustrator family 

 

Plug-in may be compatible with other graphic hosts as well. 

 

In order to uninstall plug-in run uninstaller (file uninstall.exe) or use Add and Remove Programs 
item in the Control Panel or Start Menu.  

 

User interface 
Tile Builder has 4 main sections (see description below): 

A: Toolbar 

B: Tile generation parameters 

C: Tile size and small tile preview 

D: View parameters 

 

Pressing the “OK” button causes returning to graphic host with applying object extracting. 

Pressing the “Cancel” button causes returning to graphic host without source image changing. 
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The ”Help” button runs short HTML help. 

After each parameter changing user have to press “Apply” button for re-generation seamless tile 
with new parameters. 

 

 

Current image zoom factor, progress bar and prompting line are placed into bottom of main 
window. 

A. Toolbar 

 

 Zoom – zoom in and out 
of the image when 
working with fine details 

Pan – let you scroll image 
in any direction 

Target shape – select 
part of image for tile 
generation 
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B. Tile generation parameters 

Tiling method – 
choose one of 17 tiling 
method and drag, 
rotate or bend target 
shape using control 
points to match tile 
motif 

Edge blending – 
increases edge 
blending (but 
decrease seamless 
tile size)  Apply – you need to 

press button after each 
parameter changing (or 
use double-click) 

 

C. Tile size and small tile preview 

Save Tile – save 
rectangular tile in BMP, 
JPG or PNG graphic 
formats 

Small preview – you 
can preview rectangular 
tile with tile size 

Tile size – 
increases/decrease 
seamless tile size 

 

D. View parameters  

Show Preview – runs 
window for seamless 
tile preview 

Display – Switches 
between source and 
processed images 
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Show Preview – 
main preview window. 
You can scroll image 
in any direction 

Zoom – zoom in and 
out of the image when 
working with fine 
details

Show original – 
Switches between 
source and processed 
images

 

E. Presets 

You can save and load set of parameters in preset files. 

 

 
Preset is a text file where values of plug-in parameter are written.  You can add and delete any 
preset except “Default”. 
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Working with Tile Builder 

Source data 
Plug-in can process RGB and Grayscale images with 8 or 16 bits/channel only with or without 
transparency. If you have image in other mode (Palette image, CMYK, LAB etc) – Tile Builder will 
be disabled in “Effect” menu.  

Starting Tile Builder 
Run your graphic host; open an image. Now you can run the Tile Builder plug-in. (use "Effect-
>Image Skill-> Tile Builder" menu item. NOTE: menu item can differ for different graphic hosts. ). 

 

 
 

ImageSkill Tile Builder is stared now.  
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Creation seamless patterns 
Tile Builder works under RGB and Grayscale images with 8 and 16-bit/chanell. (NOTE: Several 
hosts do not support 16-bit mode for plug-ins, so it won’t work with such graphic host in 16-bit 
mode). 

Using Tile Builder you can not “draw” pattern, you can only replicate part of your image using 
symmetry operations. So, in order to receive high quality pattern or ornament you have to have 
high quality source image. I will use “Picture Tube tool” in Corel PaintShopPro X. 

 

 

Create transparency image using 
command “File->New” and check 
“Transparency flag” 

 

Select “Picture Tube” tool and 
choose desirable theme.   

 
 

 

 

 

 

Draw a few image from selected 
tube and run Tile Builder (“Effect-
>Plugins->Image Skill->Tile 
Builder”) 

Select one of tiling methods, 
create a seamless tile, save it in 
PNG format. You can bend sides 
of target shape to match 
desirable motif. 
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Then create another tile and save 
it in PNG format too. 

We can combine two or three 
tiles to one. 

Copy tile to separate layer, then 
you can play with different blend 
modes. 
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How to create a frieze and rosette? 
In common case you can not create frieze and rosette ornament using Tile Builder directly. There 
is a trick for creation desirable décor. Simply create tile with desirable motif, save it and then edit it 
using painting and erasing tools. 

 

For example you want to create rosette with rose motif: 

   

 

Create tile, fill some image, erase unnecessary parts by 
Eraser tool. You can add a few elements also. 
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More suitable tile methods for frieze creation are methods without rotation (numbers 1-9), for 
rosette creation – otherwise (numbers 10-17) 

 

 

Tips and Tricks 
Masks, Selections and Tile Builder 

You can edit and create mask and selection using Tile Builder in order to achieve 
additional artistic effects.  

You create black-red gradient image 

 

Set mode “Edit Selection” using command “Selection->Edit Selection” 
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Then choose Paint Brush tool  and draw a white star on the 
image  

 
 

Then run Tile Builder 
using command “Effects-
>Plugins->Image Skill->Tile 
Builder” 

 

Choose one of the tiling 
methods, apply it and press OK.  
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Then turn off “Edit 
Selection” mode. 

 

You create artistic 
selection on your image and you 
can flood fill it using color, pattern 
or gradient. 

 

 

 
By the same way you can edit masks in order to hide or reveal some area on your image. 
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Use result pattern as source image to Tile Builder 

In order to increase effect range, run Tile Builder twice (or more) under the same image. 
Or you can combine patterns to each other.  

 

Saving patterns in JPG, BMP and PNG graphic formats 
What are differences between these formats?  BMP is a lossless format supported by 

majority of graphic applications. So, you do not lose any information saving result in BMP format, 
but size of BMP will be larger than JPG or PNG. If you want to exchange (export) patterns in other 
programs use BMP format. Main disadvantages of BMP are large image size and lack of 
transparency feature.   

If your pattern has transparent pixels – use PNG format. It is lossless data format with 
compression and it supports transparency. Image size will be less than in BMP, but more than in 
JPG format. 

If you will use patterns in WEB design – save it in JPG format, the resulting image size will 
be smaller than in BMP and PNG, but JPG compress image with loss, so DO NOT use JPG for 
precise work, for example textile design or likewise.  

Scripting (Actions) feature 
Some graphic hosts support scripting feature. In Corel (Jasc) Paint Shop Pro 8, 9, X, X1 it named 
as “scripts”, in Adobe PhotoShop 6, 7, CS, CS2, CS3 – “actions”. 

Using this option you can batch process a few images.  

You have to create script (action) at first. 

 

• Open an image.  

• Start script recording (“File->Script->Start Script Recordind” or button on script tool bar).  

 

 
 

• Run Tile Builder plug-in (“Effects->Plugins->Image Skill->Tile Builder”) 

• Adjust plug-in parameter for achieve desirable result. Press OK button. 

• Save script recording (“File->Script->Save  Recordind” or button on script tool bar). 
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Save script as “TileBuilder.PspScript” for example. 

 
 

Now you have script that executes Tile Builder plug-in, by default this script is saved in “Script-
Restricted” folder (see more detail in PSP help). So you can use this script for images batch 
processing or you can “Customize” your workspace by placing a button for this script to a toolbar. 

 

Customize your workspace 
You can customize your workspace in Corel (JASC) Paint Shop Pro family.  

 

• Run “Customize” command (“View->Customize”) 

• Choose “Script” tab 

• Select “TileBuilder” script, select desirable icon form thumbnails below 

• Press “Bind” button. 
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Now you can place this button on any toolbar for Tile Builder quick launch. 

 

 

NOTE: Adobe Photoshop 6,7, CS, CS2,CS3 have the similar possibilities for scripting creation 
and batch processing. For details see Abode Photoshop help. 
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FAQ and Troubleshooting 

I can not find Tile Builder in graphic host’s effect menu.  
Check is there plug-in in “Plug-Ins” graphic host’s folder, or set path to plug-in using graphic host‘s 
“Preferences” option. Re-run your graphic application. 

I can not run Tile Builder or Tile Builder is grey out in graphic 
host’s effect menu.  
Graphic hosts disable the plug-in if the current image is not suitable for use with Tile Builder. 
Image must be in RGB or Grayscale format with 8 or 16 bit/channel. If image has CMYK, LAB or 
something other format, you have to convert it to RGB or Grayscale. 

 

 

NOTE:  
If you did not find answer on your questions, write your questions to support@imageskill.com or 
send them to support forum http://forum.imageskill.com
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