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Introduction

PixPattern is a Photoshop-compatible plug-in for Windows designed by ImageSkill
Software that can work with both commercial software like Adobe Photoshop, Adobe Photoshop
Elements, Corel (Jasc) Paint Shop Pro, Microsoft Digital Image Suite, and free software like
XnView, IrfanView.

It allows you to apply beautiful, mosaic, artistic effects to your photos by choosing a
mosaic type from a predefined set of differing mosaic shapes. The plugin keeps the original color
content of your photo being able to keep the same color within any separate mosaic element. You
can enhance the mosaic effect by adjusting the size and orientation of the mosaic elements.
PixPattern has a stylish, user-friendly, intuitive, multi-lingual interface.

Features at glance

e Original algorithm of an image transformation into a mosaic
e Wide effects range

e Support script/action

e 16-bit image support

e Multilingual interface (English, German, French, Spanish, Russian)

System Requirements

Computer Pentium 400MHz

Operation System  Win2000, Win2003, Win XP, Win NT, Vista, Win7 (both 32 and 64 bits)
Hard Drive you must have free space about 10 Mb

RAM 64Mb

Miscellaneous mouse or other pointing device

You must have suitable graphic host software (see below)

Getting Technical Support

If you have any trouble, questions, feature requests or notes please contact us at the following
addresses:

E-Mail: support@imageskill.com

Web site: http://forum.imageskill.com

You can get the help you really need!
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Installing and uninstalling

Run setup file. Installer's engine automatically selects an appropriate language during installation
but still leaves a way for the user to choose language manually from the drop-list.

PixPattern

a Please select a language.

Getting Started

E3

SR

L Ok .] [ Cancel J

Then the program will ask you to close all other of the running applications. After accepting the
terms of agreement the installer finds suitable graphic hosts. Choose one of them from a list. If
you want to install plug-in in other folder, select item "Other path" and set folder for installation. In

this case you must set "Plug-ins path" of your graphic host to setup folder.

ImageSkill PixPattern 1.0 Setup

Choose a graphic host from the list.

. Irnageskill PixPattern 1.0 will install self here,
lmngeSle

Setup will install Imageskill PixPattern 1.0 in the Following Folder. To install ina other Folder,
click, 'Other location' and select another Folder, IF wou install plug-in in not 'Plug-ins' Folder of
wour host program, you must set plugin's path to setup Folder, Click Install ko continue,

Cther location
#dobe Photoshop Elements 8

Jasc Paink Shop Pro 9.0
mniiew

| C\Program FilestJast Software InciPaint Shop Pro #Pluglns) Imageskill PizPatterm

Create program's shortcuts,

Imageskill Software 2006-2010

[ <geck

Install

J [ Cancel

J

Plug-in can work under the following graphics host properly
e Adobe Photoshop 7, CS, CS2, CS3, CS4
e Adobe Photoshop Elements 3, 4, 5,6, 7, 8
e Jasc Paint Shop Pro 7, 8, 9
e Corel Paint Shop Pro (Photo) X, X1,X2, X2 Ultimate
e Corel Photo Paint 11,12, X4
e Xara Xtreme, Xara Xtreme Pro

e Microsoft Digital Image Suite 2006
© ImageSkill Software 2006-2010 3
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Plug-in may be compatible with other graphic hosts as well.

In order to uninstall plug-in run uninstaller (file uninstall.exe) or use Add and Remove Programs
item in the Control Panel of Start Menu.

User interface

PixPattern has 2 main sections (see description below):
A: Toolbar

B: Processing parameters

Pressing the “OK” button causes the returning to graphic host with applying object extracting.

Pressing the “Cancel” button causes the returning to graphic host without source image
changing.

The "Help” button runs short HTML help.
You can save and load set of parameters in preset files.

Presets:

| = A

Preset is a file where values of plug-in parameter are written. You can add and delete any preset
except “Default”.

Plug-in processes image data automatically after any parameters changing.

PixPattern [48%]

~

| = . E
If | iChck and drag to scrollimage i desired drection, (c) 2006-2010 ImageSkil .

Progress bar and prompting line are placed at the bottom of the main window.
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A. Toolbar

of the image when
working with fine details

this item to change
preferences

Zoom — zoom in and out p————e Q

Preferences — choose 3

Pan — let you scroll image

j/ ™ in any direction

AR

The active tool is marked by black border.

Tool Name

O\ Zoom

B. Processing parameters

Effect — wuse this
button for a choosing
a mosaic type

Description

Zoom in and out of the image when working with fine
details. Click to zoom-in. Right-click to zoom out. Use
mouse wheel to zoom. The title bar of the main window
displays the zoom percentage.

Let you scroll image in any direction. Click and drag to
scroll image in a desired direction.

Using this item you can change preferences like
chessboard size and color, selection annotation, and
language.

Effect

Angle — deals with the

orientation of the
mosaic elements

Scale — deals with the Scale
size  of mosaic [ ® ‘& 14
elements R

A 0
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Working with PixPattern

All example commands and images shown below are valid for Corel Paint Shop Pro Photo X2.

Source data

Plug-in can process RGB or Grayscale image with 8 or 16 bits/channel only with or without
transparency. If you have an image in another mode (CMYK, LAB etc.) — PixPattern will be
disabled in the “Effect” menu.

If you want to work with palette image (like GIF, palette BMP etc) you must transform it to 24 bit
color image at first using Image->Increase Color Depth->16 Millions Colors (24 bits).

Change language

The PixPattern has five-lingual interface (English, German, French, Spanish and Russian). To
change the language in the process of working with the plug-in you need to click on Preferences
item % and select “Change language”. Then choose an appropriate language from the drop-list
and click OK button. Close the application and restart it again to apply the new language.

Preferences |E|

Transparency Select language: ‘English {United States) ‘
Selection

_hange language

[ K J [ Cancel

Starting PixPattern

Run your graphic host. Open an image (for example camera shot in JPG graphic format). Now
you can run the PixPattern plug-in. (use "Effects->Plugins->Image Skill->PixPattern" menu item).

So, just now we have suitable data (RGB image with 8bit/chanall) and we can run PixPattern
using “Effects->Plugins->Image Skill->PixPattern” command.

© ImageSkill Software 2006-2010 6
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™ Corel Paint Shop Pro Photo X2 - IMG_21052
Fie Edt Yew Image Adjust Effedts  Layers  Objects  Selechions  Window Hep

. o [’: » " vr Effect Browser, 8. Zoom out 8.‘ Zoomin | By "R~

X Prasatn Selection type:

Smoothing!

Anti-alas

»
1 0 [ A |
l. n: B o ol layen

3D Effects
Art Meda Effects
Artistic Ervects

Dastortion Effects

Geometric Effects
Hlumination Effacts
image Effects
Photo Effects
l_-'ﬁ"f}"'l‘ﬂ Effects

axturs Effects

S \onman e = T

User Defined Fiker
Flugins Imaze Skl b PixPattern Demo
PecPattern,..

If you do not see PixPattern in menu, see our tutorial See How to attach plugin to Corel (Jasc)
PaintShopPro at our forum (http://forum.imageskill.com/index.php/topic,1551.0.html)

Adjust plug-in parameters to achieve a desirable result. See parameters description above.
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PixPattern [97%]

Effects

(c) 2006-2010 ImageSkil .

Press OK button and return to the host.

Scripting (Actions) feature

Some graphic hosts support scripting feature. In Corel (Jasc) Paint Shop Pro 8, 9, X, X1, X2 it
named as “scripts”, in Adobe PhotoShop 6, 7, CS, CS2 — “actions”.

Using this option you can batch process a few images.

You have to create script (action) at first.

e Open an image.

e Start script recording (“File->Script->Start Script Recordind” or button on script tool
bar).

© ImageSkill Software 2006-2010 8
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Corel Paint Shop Pro X

File Edit Mew Image Adjust Effects Layers Objects  Selections
1 — B ™

OBk ()

Prezets; | = Zoom [ %0

:

plug_in L b2 i

. Skart Scripk Recarding

Zoom out fing | Zoor more: | Actual size:

e Run PixPattern plug-in (“Effects->Plugins->Image Skill->PixPattern”)
e Adjust plug-in parameter for achieve desirable result. Press OK button.

e Save script recording (“File->Script->Save Recordind” or button on script tool bar).

Corel Paint Shop Pro X - IMG_1273.JPG

File  Edit Wiew Image  Adjust  Effecks  Lawvers Objects  Seleckions Window  He

Lo B © v B 2T @ W ¥ EnhancePhot
Presets;  Zoom [ %1 Actual size:
- [ 5. | @@O
plug_in - > % g i X
B IMG_1273.0PG* @ 34% {Background) Save Script Recording !

Zoorn out Jing | Zoorn more:

™ ™
- i
- +'\.

— .|...-ii

Save script as “PixPattern.PspScript” for example.

Save in: I (J Scrptz-Restncted ﬂ 0 (F e

&% | M51.PspScript

&+ M5, PspScript

&% plug_in1.PspScripk
&% | plug_in.PspScript
&} | resize, PspScripk

File name: — |PixPattern PspScript 28ve
Save as type: ISn:ripI Files [*. PspScnpt] ﬂ Cancel
¥ Save Materials v Remove Undone Commands Description. ..

[~ Save Dialog Positions

© ImageSkill Software 2006-2010 9
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Now you have script that executes PixPattern plug-in, by default this script is saved in “Script-
Restricted” folder (see more detail in PSP help). So you can use this script for images batch
processing or you can “Customize” your workspace by placing a button for this script to a toolbar.

Batch Processing

Run Batch Process command (“File->Batch Process”).

Batch Process Ed

Eiles to process:

E:\Photo\MG_1348.JPG
E:\Photo\MG_1744.JPG
E:-\PhotoMMG_1720LPG
E:\PhotoMMG_1736.PG
E:\PhotoMMG_1836.JPG
E:\Photo\MG_1848.JPG
E:\PhotoMMG_1850.JPG
E:\Photo\MG_1920.JPG
E:\Photo\MG_1975.JPG
E:\Photo\MG_1996.JPG
E:\PhotoMMG_1337.JPG
E:\PhotoMMG_2057.JPG
E:\PhotoMMG_2036.JPG
E:\PhotoMMG_2037.JPG
E:\Photo\MMG_2105.JPG
E:\Photo\MG_2146.JPG
E:\Photo\MG_2167 JPG
E:\Photo\IMG 2172.JPG

= Browse...

Bemave Eromlist

Stat

Carcel

~| ¥ Stop on enor

~ Scipk

FixPattern

¥ Use Script
v Silent mode

=l

= Save Mods:
" Mew Type
= Copy

" Dyenwite

" Sciipt Save

~ Save Dptions:
Type:

Folder:

I BMP Windows or 05/2 Bitmap [* bmp)

j [ proris

D:\processedy

Mew file name:

Browse...

Modify...

© ImageSkill Software 2006-2010

10

Select images for
processing by
“Browse” button.

Choose
“PixPattern” as
script.

You can run it in
“Silent” mode, and
then all images will
processed with the

same plug-in
parameters as you
recorded script.
The plug-in

windows won’t be
appearing.

If you run it in
“Interactive” mode,
you will able adjust
plug-in parameters
in  plug-in’s  main
window.

Result  will be
saved depended of
“Save Mode”

parameter. Choose
the "Copy” and set
output folder. In this
case the result will
be saved in this
folder with  the

same name.
Press “Start”
button. The

selected images
will be processed.
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Customize your workspace
You can customize your workspace in Corel (JASC) Paint Shop Pro family.

e Run “Customize” command (“View->Customize”)
e Choose “Script’ tab
o Select “PixPattern” script, select desirable icon form thumbnails below

e Press “Bind” button.

Customize E

Commands | Toolbars | Keyboard | Menu | Options Seripts |

— Select a zcnpt and an icon to create a new binding:
| PixPattern ~] Bind

@ @ ¢ (@ ¢ -
a & sl & &

— Bound Scripts:
& PixPattern

Hmnvel

Cose |  Hep |

Now you can place this button on any toolbar for PixPattern quick launch.

NOTE: Adobe Photoshop 7, CS, CS2 have the similar possibilities for scripting creation and batch
processing. For details see Abode Photoshop help.

© ImageSkill Software 2006-2010 11
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FAQ and Troubleshooting

| can not find PixPattern in graphic host’s effect menu.

The PixPattern like other our products is Adobe -compatible plugin. It is mean, that this product
can work as plug-in with any graphic editor, that supports Photoshop's plug-ins (Corel(Jasc) Paint
Shop Pro 7, 8, 9, X, X1, X2, XnView, All Adobe graphic family etc.).

In most cases installer detects the suitable host automatically and copy plugin in needed place.
But some cases (alpha or beta version of products, international or custom version) installer fail.
But any case you can attach plugin to host.

Check is there plug-in in “Plug-Ins” graphic host’s folder, or set path to plug-in using graphic host's
“Preferences” option. Re-run your graphic application.

For Corel PSPX 2 you can find Background Remover in "Effects->Plugins->Image Skill" menu.

You can see how to attach plugin to Corel (Jasc) PaintShopPro
http://forum.imageskill.com/index.php/topic,1551.0.html

For Adobe family you can find Background Remover in "Filters->Plugins->Image Skill" menu.

You can see how to attach plugin to Adobe graphic family (Photoshop, PhotoShop Elements)
http://forum.imageskill.com/index.php/topic,1128.msg1210.html#msg1210

If you have no graphic editor you can use Background remover with good free editor XnView:
http://forum.imageskill.com/index.php/topic,1502.0.html

| can not run PixPattern or PixPattern is grey out in graphic
host’s effect menu.

Graphic hosts disable the plug-in if the current image is not suitable for use with Background
Remover. Image must be in RGB format with 8 or 16 bit/channel and must have a layer (i.e.
image must have 4 channels: R, G, B, and Alpha). If image has CMYK, LAB, Grayscale or
something other than RGB format, you have to convert it to RGB. If image has no layer you have
to create it at first.

How does plug-in process selection?

The PixPattern affects to selected area only. The unselected area is still unchanged. The
unselected area is shown with red semi-transparent color in main plug-in window. Plug-in deals
with the bounding box selection.

© ImageSkill Software 2006-2010 12
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Image with selection The unselected area is filled by Result of the processing
semi-transparent red color

NOTE:

If you did not find answer on your questions, write your questions to support@imageskill.com

or send them to support forum http://forum.imageskill.com

© ImageSkill Software 2006-2010 13


mailto:support@imageskill.com
http://forum.imageskill.com/

	Table of Contents
	Introduction  
	Features at glance 
	System Requirements 
	Getting Technical Support 

	Getting Started 
	Installing and uninstalling 
	User interface 
	A. Toolbar 
	B. Processing parameters 

	Working with PixPattern 
	Source data 
	Change language 
	Starting PixPattern 
	Scripting (Actions) feature 
	Batch Processing 
	Customize your workspace

	FAQ and Troubleshooting 
	I can not find PixPattern in graphic hos
	I can not run PixPattern or PixPattern i
	How does plug-in process selection? 


