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Introduction 

Magic Sharpener is an amazing image sharpening, Photoshop-compatible plug-in for Windows 
Operating System, designed by ImageSkill Software. The plug-in can also work with other 
commercial software like Adobe Photoshop Elements, Corel (Jasc) Paint Shop Pro, Microsoft 
Digital Image Suite and other free software such as IrfanView and XnView.   

Magic Sharpener dramatically improves the look of images by intelligent, sharpness enhancement 
but without the appearance of color halos and increased noise. The plug-in is now supplied with a 
new brushed selective sharpening function. These are the main features that distinguish this plug-
in from our competitors. Magic Sharpener is very useful where a digital camera whose lens in 
itself yields a slightly unsharp photograph. The plug-in has a stylish, user-friendly, intuitive, multi-
lingual interface. 

Everyone dealing with sharpening technique knows how annoying noise exaggeration may be 
when noise is mixed with image details. Magic Sharpener is able to prevent noise amplification in 
the sharpening process; all you need is to switch on the relevant check box, choose an image 
area where noise is obvious, and adjust the noise level.  

Features at a glance 
• High quality image sharpening without halo defects. 

• Removal of JPEG artefacts. 

• Noise suppression feature. 

• Original high-speed sharpening algorithms. 

• Script (action) feature. 

• 16-bit mode support. 

• Multi-lingual interface. 

• Brushed selective sharpening function 

  

System Requirements 
Computer:  Pentium 400 MHz. 

Operating System: Win98, Win200, Win2003, Win XP, Win NT3, Win NT4, Win Vista 

Hard Drive:  You must have at least about 3 MB of free space. 

RAM:  64 MB. 

Miscellaneous:  Mouse or other pointing device. 

  You must have a suitable graphic host software (see below). 

Registering ImageSkill Magic Sharpener 
You can order the full version of this plug-in via ShareIt and RegNow services (both of them 
accept PayPal). If you purchase Magic Sharpener through these services, you receive a user 
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name and an unlock key. Please enter them carefully without additional blanks. Use the copy-
paste method to avoid errors. 

If you have any trouble with your unlock key, please send an email to sales@imageskill.com

Registered users will receive our email newsletter containing information about new product 
releases and updates, free downloads, articles, tips, and special offers. 

At the moment, any upgrades to our products are given to registered customers free of charge. 

Getting Technical Support 
If you have any troubles with installation, questions, feature requests or notes, please contact us 
by one of the following ways: 

E-Mail: support@imageskill.com

Web site: http://forum.imageskill.com
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Getting Started 

For those not interested in the details about sharpening please continue below at 'Installing and 
Uninstalling'." 

Sharpening overview 
 

Sharpness - A photographic term for perfectly defined detail in an original, negative and reproduction. 

 

What is sharpening? 

Everyone who deals with images can tell which of them are sharp and which are not, but nobody 
can state what sharpness actually means in some physical sense. Unfortunately, psychophysical 
impressions are not formalized yet, and this creates some problems in sharpening tool design. It 
is well known that sharpness is actually determined by resolution and acutance. From an optical 
point of view, resolution means the ability of your lens and sensor to register fine details in your 
image: the more fine details you can capture, the higher resolution you have. If you have lost 
details for whatever reason, no sharpening tool can help you reveal them; if the contrast of fine 
details has been lost, no sharpening tool can help you to increase the contrast properly. The latter 
situations are relevant to the focus restoration problem, and you need to have a special tool for 
doing that. All you can achieve with sharpening tools is acutance manipulation; in other words: 
you can make edges sharper. This means that the edge transition from one side to the other will 
be quicker.  

Psychophysical data show that for a given image resolution, perceived sharpness can be 
increased, in general, by contrast enhancement, by adding a reasonable amount of additive 
uniform noise, and by using standard spatial sharpening techniques implemented in various 
graphical packages like Adobe Photoshop, and plug-ins like Nik Sharpener Pro. 
 

Why image appears soft? 

The first reason for an image to appear soft is the transformation into discrete pixels of 
continuous gradations of tone and color that exist in the real world. Softness here is the result of 
light spatial averaging across a tiny area of the digital camera sensor element, software 
calculation of color for each pixel and assignment of that color value to the pixel, and the finite 
number of bits used for storing the data per pixel. 

 The second reason for image softness is the lens. No lens is a perfect optical system and 
spread (blur) even point sources in object space projected through them; this means that the 
projected point source image will never be a point but will be blurred depending on the quality of 
the lens. The amount of blurring is determined by the lens’ point-spread function (PSF), or 
impulse response. Its characteristics depend on aberrations in the optical system spreading the 
image over a finite area, diffraction effects also spreading the image, even in a system with no 
aberrations. The lower extended the PSF, the finer the detail and the sharper the image. 
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The third reason of image softness is that, for any given lens settings, there is only one distance 
from a lens at which an object is precisely in focus, and focus falls off gradually on either side of 
that distance. So there is a region in which the blurring is tolerable; this region is greater behind 
the point of focus than it is in front of it. The distance in front of and behind the object which 
appears to be in focus is called depth of field; any objects lying outside this distance will not be 
sharp enough. 

The three reasons mentioned above are, in some sense, fundamental ones. They define the low 
limit for image softness for a desired object if the user takes the photograph properly; a 
photographer can only increase the image softness. So, the next reasons can be considered 
purely subjective. 

The fourth reason is wrong focus setting, when one has so-called “out of focus” shots where the 
image becomes very soft.  

The fifth reason for soft images is when one makes photos of moving objects, or from a moving 
camera. Here one has to deal with the so-called “motion blur effect”, where the image will look 
blurred or smeared along the direction of object and/or camera relative motion. Sometimes motion 
blur can produce dramatic pictures but can destroy the image as well. 

Installing and uninstalling 
Download and run the setup file. The installer automatically selects a language during the 
installation but still allows the user to choose a language manually from the drop-down list. 

 

 
 

After pressing the “OK” button the installer finds all the suitable graphic hosts on your computer. 
Choose one of them from the list and then the installer automatically installs the plug-in. If you 
want to install the plug-in in another folder, select item "Other path" and set the path. In this case 
you must set the "Plug-ins path" of your graphic host to setup folder. 

Plug-in’s installer automatically detects the following graphic host applications: 

• Adobe Photoshop 7, CS, CS2, CS3 and CS4 

• Adobe Photoshop Elements 2, 3, 4, 5 

• Jasc Paint Shop Pro 7, 8, 9 

• Corel Paint Shop Pro (Photo) X, X1, X2 Ultimate 

• Corel Photo Paint 11, 12, 13 

• Xara Xtreme 
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• Microsoft Digital Image Suite 2006 

• Macromedia Fireworks 2004, 8 

• Ulead PhotoImpact 8, 9, 10, 11, 12 

 

Plug-in can also work under the following graphics hosts 

• XnView 1.8 and older 

• IrfanView 

• Corel Painter  

 

This is not an exhaustive list.  The plug-in may be compatible with other graphic hosts as well. 

 

In order to uninstall the plug-in run uninstaller (file uninstall.exe) or use Add and Remove 
Programs item in the Control Panel or Start Menu. 

 

User interface 
Magic Sharpener has 4 main sections: 

A: Toolbar 

B: Processing parameters 

C: Presets 

D: Preferences 

Pressing the “OK” button causes any processing to be carried out on the full image and a return 
to the host program. 

Pressing the “Cancel” button causes a return to the graphic host leaving the source image 
unchanged. 

The “Help” button runs short HTML help. 

 

The plug-in processes image data automatically after changing any of the interface parameters in 
B. 
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Current image zoom factor, progress bar and prompting line are placed at the bottom of the main 
window. 

A. Toolbar 

 

 Zoom – zoom in and out 
of the image when 
working with fine details Pan – lets you scroll the 

image in any direction 

Preferences – Using this item 
you can change preferences 
like chessboard size and color, 
selection annotation and 
language.  

Brush for local 
sharpness correction – 
click this tool to adjust 
sharpness locally 
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B. Processing parameters 

Radius – changes the 
size of the image 
fuzziness in pixels. 

Line contrast – 
increases the 
amplitude and 
steepness of the fine 
details in an image 

Prevent noise 
amplification – check 
this flag to prevent 
noise increasing as in 
selected noisy image 
sample.  

Click to select noise 
sample – allows the 
selection of a noisy image 
area of a fixed size.

Remove JPEG 
Artefacts  – check this 
flag in order to remove 
JPEG artefacts.

Edge sharpness – 
increases edge 
steepness 

Noise level – 
decreases the extent 
of noise amplification 

 

 

 

 

Brush properties 

If you are going to adjust sharpness locally click the brush icon  in the toolbar, choose the 
option Decrease or Increase from the Sharpness mode and set the brush properties (size, 
hardness and opacity) – see below.  
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Move the brush stroke to the place where you want to decrease or increase the 
sharpness locally and click the left mouse button. Assuming you start with an image 
which you have just sharpened using the plug-in, you can use the brush to locally reduce 
the sharpness but by no more than the plug-in sharpened it – see left image below.  That 
means you are back to the original, untouched image.  In contrast to this, the brush may 
be used to increase the sharpness but by no more than is possible with the plug-in – see 
right image below. 

             
      Local sharpness decreasing behind the leaf.     Local sharpness increasing of the eyebrow. 

 

To reverse the effect of local sharpness correction you need to click the right mouse button. 

Clicking on the Reset marked area button you can cancel the result of the local sharpness 
correction. 

 

C. Presets 

You can load and save sets of parameters in preset files. 

 

 
A preset is a text file where values of plug-in parameters are written.  You can add and delete any 
preset except “Default”. 

D. Preferences 

Choose this item to change the preferences of the plug-in. Using it, you can change preferences 
like chessboard size and color, selection annotation, and language. 

 

© ImageSkill Software 2006-2009 9



ImageSkill Magic Sharpener: User’s Manual 

 

The Magic Sharpener plug-in has a multi lingual interface (English, German, French, Italian, 
Spanish, Dutch, Russian, Japanese, Chinese Simplified, and Chinese Traditional). To change the 
language while working with the plug-in, you need to click on the “Preferences” item and select 
the item “Change language”; then choose an appropiate language from the drop list and click the 
“OK” button. Close the plug-in main window and restart it again for the new language to be 
applied. 
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Working with Magic Sharpener 
All example commands and images are valid for Adobe PhotoShop CS4. 

Source data 
The plug-in can process RGB and Grayscale images with 8 or 16 bits/channel only with or without 
transparency. If you have an image in another mode (CMYK, LAB etc) – Magic Sharpener will be 
disabled in “Effect” menu. See FAQs for another reason why all the plug-ins may be grayed out.  

Starting Magic Sharpener 
Run your graphic host (for example, Adobe Photoshop CS4) and open an image. Now you can 
run the Magic Sharpener plug-in (use the "Filter -> Image Skill -> Magic Sharpener" menu item). 
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ImageSkill Magic Sharpener will start now.  

Image sharpening 
The Image sharpening plugin is used when your image needs sharpening. To make it sharper, 
you need to set appropriate processing parameters at the user interface mentioned above.  

 

• Set the Radius value first. Bear in mind that the softer an original image is, the higher the 
Radius value that ought to be chosen. 

• Set the Edge sharpness parameter. It varies from 0 to 100%; the higher the value, the 
more edge steepness you will get. At a 100% Edge sharpness value, the transition 
between relatively light and dark areas will be the narrowest for the given Radius value. 

• Adjusting the Line contrast parameter, increases the amplitude and steepness of fine 
details in an image such as a single hair that is a blurred line in the original. This 
parameter varies from 0 to 500% and gives you the possibility to oversharpen fine details 
in some sense. Sometimes it can give a very unusual, artistic impression to your 
processed image. 

• Activating the Prevent noise amplification check box avoids increasing the amplitude of 
some noise patterns that would otherwise be treated as fine details. The selection of such 
pattern is done with the Click to select noise sample button; left mouse click-and-hold 
lets you move a small box over the image to a place where the appropiate noise sample is 
located. Afterwards, a review above this button will show you what noise sample has been 
chosen. Using the Noise level slider, you can decrease the extent of noise amplification 
by setting the Noise level value higher.  

• Activate the Remove JPEG Artefacts check box if your image has JPEG artifacts.  

• Activate the Brush for local sharpness correction clicking on the corresponding brush 
icon in the toolbar box if you are going to adjust the sharpness locally, select the 
Sharpness mode and choose the brush parameters. In this case you start with the 
sharpened image and decrease its sharpness locally up to the sharpness of the original 
image.  

 

The default parameters are suitable for most images.  

Scripting (Actions) feature 
Some graphic hosts support scripting features. In Corel (Jasc) Paint Shop Pro 8, 9, X, X1 and X2 
this is called “scripts”, and in Adobe PhotoShop 6, 7, CS, CS2, CS3 and CS4 it is called “actions”. 

Using this option you can batch process several images.  

 

Working with Photoshop CS4 you have to create an action first: 

 

• Open an image.  
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• Show the actions palette  (“Window → Actions or Alt + F9) and click the little arrow in the 
upper-right palette corner to open the actions flyout menu 

• Start creates new action clicking on the “Create new action” button in the Actions palette 
(see below) or choose New Action from the Actions palette menu  

 

 
 

• Enter an action name (for example, Magic Sharpness), select an action set and set 
additional options. 

 

 
 

            Then click the Record button. The Begin recording button in the Actions palette turns  

            red . 

• Run the Magic Sharpener plug-in (“Filter → Image Skill → Magic Sharpener”) 

• Adjust the plug-in parameters to achieve the desirable result. Press the “OK” button. 

• To save an enhanced copy of your image automatically in the same folder go to File → 
Save As and choose, for example, JPEG for the save format. Check “As a Copy” in the 
save options to be sure you save a copy. Click OK and choose your quality and format 
options in the JPEG Options dialog. Click OK again to save your enhanced image.  

• To stop recording the “Magic Sharpness” action either click on the “Stop playing/recording” 
button in the Actions palette (see below) or choose Stop Recording from the Actions 
palette menu 
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Now you will have the “Magic Sharpness” action that executes the Magic Sharpener plug-in and 
saves a copy in the same folder from which the original image was taken. To run this action you 
need to select it in the actions flyout menu and click the “Play selection” button in the Actions 
palette 

 
 

You can use this action for batch processing images, or you can “Customize” your workspace by 
placing a button for this script in a toolbar. 

 

Batch Processing 

To use “Magic Sharpness” action for batch processing images run the Batch command (“File → 
Automate → Batch”).  

In the Batch dialog box (see below) select the set and “Magic Sharpness” action under the “Play” 
section. 

In the “Source” section choose Folder and click “Choose…” to browse to the folder which contains 
the images you want to sharpen. 

In the “Destination” section choose Folder and click “Choose…” to browse to the folder which will 
contain your sharpened images. 

Check the box “Override Action “Save As” Commands” to save your enhanced images in the 
destination folder without prompting. 

In the “File Naming” section you can use the original document (image) name. 
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After setting your options, click OK to run the images batch processing. The Photoshop CS4 
sharpens all your images in the source folder automatically. 

 

NOTE: Corel (Jasc) Paint Shop Pro 8, 9, X, X1 and X2 have similar facilities for script creation 
and batch processing. See the relevant sections in help documentation for details. 

 

Customize your workspace in Corel (JASC) Paint Shop Pro family. 
 

• Run “Customize” command (“View -> Customize”). 

• Choose the “Script” tab. 

• Select the “MagicSharpener” script, choose a desirable icon from the thumbnails below. 

• Press the “Bind” button. 

 

You can customize your workspace so that features you use most often are easily accessible. 
Just get it set up the way you like, and then go to Window > Workspace > Save Workspace. 
The Workspace menu also has preset workspaces for different types of work, such as printing 
and proofing, color correction and web design. 
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Now you can place this button on any toolbar for Magic Sharpener quick launching. 
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FAQ and Troubleshooting 

I can’t find Magic Sharpener in my graphic host’s Effects/Filter 
menu. 
Check that the plug-in is in the graphic host’s Plug-ins folder, or, if necessary, set the path to the 
plug-in using the graphic host‘s “Preferences” option.  

To do this in the Jasc (Corel) PSP click File -> Preferences -> File Locations -> Plug-ins and add 
the path to the plug-in. Re-run your graphic host. 

 

 
 

Note: In the Adobe Photoshop click Edit -> Preferences -> Plug-ins and add the path to the plug-
in. Re-run your graphic host. 

I can’t run Magic Sharpener, or Magic Sharpener is greyed out 
in the graphic host’s Effects/Filter menu.  
Graphic hosts disable the plug-in if the current image is not suitable for use with Magic Sharpener. 
The image must be in RGB or Grayscale format, with 8 or 16 bit/channel. If the image is in CMYK, 
LAB or something other format, you have to convert it to RGB or Grayscale. 

 
NOTE: If you did not find an answer to your questions, send them to support@imageskill.com, or 
to the support forum at http://forum.imageskill.com. 
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