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Introduction  
Background Remover is a Photoshop-compatible plug-in for Windows designed by ImageSkill 
Software that can work with both commercial software like Adobe Photoshop, Adobe Photoshop 
Elements, Corel (Jasc) Paint Shop Pro, Microsoft Digital Image Suite, and free software like 
XnView.  

The main purpose of the Background Remover is to extract some part of an image i.e. “the object” 
and remove other part that is unwanted, i.e. “the background”. It is capable of determining areas 
of pixels to be modified, areas of pixels to be partly modified and areas of pixels to remain 
unchanged. The partial modification means the restoration of the non-distinct edges of objects in 
partly transparent regions that is done by the subtracting the background color but leaving object’s 
color there. It allows a user to blend or composite the cut-out object with a different background 
properly. The cutting objects may be used for collage, scrap-book and greeting card creation.  

Using Background Remover you can get a result you really want that is unachievable with other 
masking programs like Adobe Magic Extractor, Corel Knock-Out, Microsoft Expression and so on. 
And it takes very little time and efforts on your part.  

You do not need mark an object and background accurately. Simply mark a few parts of them by 
special tools and get a desirable result nearly instantly. This result can be adjusted by one slider 
only but there are additional tools for its fine tuning. If necessary you can also use erase/restore 
brush for the manual correction of the background removing. To control the quality the result you 
can preview the extracted object against colored matte background. 

Features at glance 

 Extraction of different object types (solid, lace-like and semi-transparent objects) 

 Very simple and intuitive user interface with only a few controls  

 Original high-speed extraction algorithms  

 Color unmixing for background replacing 

 Tools for debris removing and holes filling within received mask 

 Switching between original image and result one and preview the extracted object against 
a colored matte background for result checking. 

 Multilingual interface (English, German, French, Italian, Spanish, Dutch, Russian, 
Japanese, Chinese Simplified, and Chinese Traditional) 

 16-bit image support  

System Requirements 

Computer  Pentium 400MHz 

Operation System  Win2000, Win2003, Win XP, Win NT3, Win NT4, Vista, Windows 7 

Hard Drive  you must have free space about 10 Mb 

RAM  64Mb 

Miscellaneous   mouse or other pointing device  

  You must have suitable graphic host software (see below) 
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Registering ImageSkill Background Remover 

You can order full version of this plug-in via ShareIt and RegNow services (either accept PayPal). 
If you buy Background Remover through these services you receive user name and unlock key. 
Please, enter their carefully without additional blanks. Use copy-paste method. 

If you have any trouble with unlock key, write sales@imageskill.com 

Registered users receive our email newsletter containing information about new product releases 
and updates, free downloads, articles, tips, and special offers and discounts. 

Just now, we upgrade our products for registered customer free of charge. 

Getting Technical Support 

If you have any trouble, questions, feature requests or notes please contact us at the following 
addresses: 

E-Mail: support@imageskill.com 

Web site: http://forum.imageskill.com 

You can get the help you really need! 

Examples 

Source image Extracted image 

  

  

mailto:sales@imageskill.com
mailto:support@imageskill.com
http://forum.imageskill.com/


ImageSkill Background Remover: User’s Manual 

 

 ImageSkill Software 2006-2009 4 

Getting Started 

Installing and uninstalling 

Run setup file. Installer's engine automatically selects an appropriate language during installation 
but still leaves a way for the user to choose language manually from the drop-list. 

 

Then the program will ask you to close all other of the running applications. After accepting the 
terms of agreement the installer finds suitable graphic hosts. Choose one of them from a list. If 
you want to install plug-in in other folder, select item "Other path" and set folder for installation. In 
this case you must set "Plug-ins path" of your graphic host to setup folder. 

 

Plug-in can work under the following graphics host properly 

 Adobe Photoshop 7, CS, CS2, CS3, CS4 

 Adobe Photoshop Elements 3, 4, 5, 6, 7 

 Jasc Paint Shop Pro 7, 8, 9 

 Corel Paint Shop Pro (Photo) X, X1,X2, X2 Ultimate 

 Corel Photo Paint 11,12, X4 
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 Xara Xtreme, Xara Xtreme Pro 

 Microsoft Digital Image Suite 2006 

 

Plug-in may be compatible with other graphic hosts as well. 

 

In order to uninstall plug-in run uninstaller (file uninstall.exe) or use Add and Remove Programs 
item in the Control Panel of Start Menu.  

User interface 

Background Remover has 3 main sections (see description below): 

A: View parameters 

B: Toolbar 

C: Tool’s parameters 

 

Pressing the “OK” button causes the returning to graphic host with applying object extracting. 

Pressing the “Cancel” button causes the returning to graphic host without source image 

changing. 

The ”Help” button runs short HTML help. 
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Progress bar and prompting line are placed at the bottom of the main window. 

 

 

The number of undo/redo steps depends of physical computer’s memory. 

Undo – undo last 

command 

Redo – redo last 

command 
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A. View 

 

 

You can switch between source, processed images and mask at any time. 

 

The last option allows you to place temporarily the extracted object against a chosen matt with 
uniform color. It makes easier to evaluate visually how this object will be looked like in a future 
composition on various backgrounds. Note, that this placement is only temporary one. After exit 
the Background Remover the main graphic editor places the result on chessboard again.  

 

 

 

From left to right:  

Source (original) image, Result of extraction, Result Mask, Result image on grey background. 

View source (non-
processed) image Use to preview the 

extracted objects 
against a colored 
matte background. 

 

View mask  

(grayscale image) 

 

View result image on 
chess background 
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B. Toolbar 

 

The active tool is marked by black border. 

 

Tool Name Description 

 
Zoom

 

Zoom in and out of the image when working with fine 
details. Click to zoom-in. Right-click to zoom out. Use 
mouse wheel to zoom. The title bar of the main window 
displays the zoom percentage. 

 

 
Pan

 

Let you scroll image in any direction. Click and drag to 
scroll image in a desired direction.  

 

Reset – reverts all 

operations 

Zoom – zoom in and out 

of the image when 
working with fine details 

Mark colors for erasing 

– use this tool for marking 
background (red marks) 

Manual Eraser – use this 

brush to remove/restore 
some parts of the image 
manually 

Pan – let you scroll image 

in any direction 

Magic Fill – use this tool 

to remove background 
colors on the whole image 

Delete all marks – drop 

all marks 

Mark object – use this 

tool for marking object 
(green marks) 

Preferences – choose 

this item to change 
preferences 

Magic Wand – use this 

tool to cut out object 

Mask Defringe zone – 

use this tool to mark zone 
for color unmixing  

Refine Mask – use this 

tool to refine mask 
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Mark colors for erasing

  

 

 

 

Use this tool for the marking background (red marks). Click 
and drag to mark background. Use Right-click to erase 
marks (both object’s and background’s marks are erased). 
Use Ctrl button combination (press and hold Ctrl button) in 

order to switch to Mark object tool. 

 

 

 

 
Mark object 

 

 

 

 

Use this tool for the marking object (green marks). Click 
and drag to mark object. Use Right-click to erase marks 
(both object’s and background’s marks are erased). Use 

Ctrl in order to switch to Mark colors for erasing tool. 

 

 

 Delete all marks
 

 

 

Drop all marks and fix current result. After pressing this 
button you return to a previous active tool. 

 

 

 

 
Manual Eraser 

 

 

Click and drag for erase. Right-click and drag for unerase. 
You can adjust brush size, opacity, hardness and step. 
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Magic Wand 

 

This is the main image extraction tool. Use the Magic 
Wand in order to extract connected object like people, 

things etc. Click and drag to erase background. Use Right-
click to restore object. You will process only connected 
local area, not whole image. 

You can adjust the aggressiveness of the background 

elements removing by Strength parameter. The greater its 

value is set the more stronger background is removed. 

If you process image where object are placed on textured 

background, check flag Textured Background.  

You can refine the resulting mask by contraction (if the 
result image has colored border around cut object). Set 

Strength parameter to a specific number of pixels that you 

want to contract the mask. 

You can smooth transition between the object and the 

background by increasing Feathering parameter. 

In order to fill holes in the resulting mask check the Fill 
Holes flag. Then all areas marked as background will be 

saved in the result image; while other ones marked as 
object and debris will be go away. 

 

 

 

 
Magic Fill 

 

 

 

 

This is super significant image extraction tool. Use the 

Magic Fill in order to extract disconnected objects like 

brunches of tree, jewelry etc. Click and drag to erase 
background. Use Right-click to restore object. You will 
affect on whole image. Pixels with colors that look like 
colors marked as background will be processed. To some 
of them the transparency value will be assigned. If object 

and background share some colors, check Resolve 
Colors flag. 

You can refine result mask by adjusting the Contrast 
parameter. 
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Refine Mask 

 

Use this tool for the result mask refinement.  

Use Contract slider to contract mask in order to avoid 

undesirable border around cut objects.  

You can smooth transition between object and background 

by increasing Feathering parameter. 

Use Boundary Smoothing slider to smooth mask's 

border. 

Use Contrast slider to binarize mask. 

Adjust Fill Holes and Remove Speckle in order to fill 

holes and remove debris in the result mask respectively.   

 

 

 
Reset 

 

Revert all operations and reset image to the original one. 

 

 
Preferences 

 

Using this item you can change preferences like 
chessboard size and color, selection annotation, and 
language.   
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Working with Background Remover 

All example commands and images shown below are valid for Adobe Photoshop CS3. 

Source data 

Plug-in can process RGB layer data with 8 or 16 bits/channel only. If your image has no layer you 
must create one at first. If you try to run ImageSkill Background Remover under flat (background) 
image data you receive the following message  

 

If you work with palette image (like GIF, palette BMP etc) you must transform it to 24 bit color 
image at first. 

Change language 

The Background Remover 3.2 has ten-lingual interface (English, German, French, Italian, 
Spanish, Dutch, Russian, Japanese, Chinese Simplified, and Chinese Traditional). To change the 

language in the process of working with the plug-in you need to click on Preferences item  
and select “Change language”.  Then choose an appropriate language from the drop-list and click 
OK button. Close the application and restart it again to apply the new language. 
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Starting Background Remover 

 

Run your graphic host. 

 

Open an image (for 
example camera shot in 
JPG graphic format).  

This is background 
image in RGB graphic 
format 8-bit/channel. This 
image has no layer data 
yet.   It means that image 
does not have 
transparency property 
(so-called “Alpha 
channel”) 

You can check it by 
“Layers” window. (Use 
menu item “Window-
>Layers” or press short-
key F7). 

 

In order to use Background Remover you must add “Alpha channel” in image data, i.e. to create 
layer from a flat image.  

You can do it by using “Layer->New->Layer from Background” command. 

 

 

ATTENTION: DO NOT USE “Layer->Duplicate Layer” or “Layer->New->Layer via copy” 
commands. Otherwise you receive 2 identical images. The lower one having name 

“Background” is your source image, while the second one having name “Layer 0” is the 

duplicated layer (your image + alpha channel). Just after Background Remover processing 

Image mode 

(RGB, 8 bit/channel) 

 

Layer palette 

(No layers, only background, image 
has not transparency property) 
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(when you press OK button in Background Remover main dialog window), you will not see the 

result but the source image (“Background”) only that is viewed through processed layer (“Layer 
0”).  

 

To avoid the feeling that Background Remover does nothing please use “Layer->New->Layer 
from Background” command always. 

Please control your data in “Layer” palette (hot key- F7). After applying the command “Layer-
>New->Layer from Background” it should show the following  

 

 

In “Layer” palette you have only 1 layer 

with name “Layer 0”. 

 

 

So, just now we have suitable 
data (RGB image with 
8bit/chanall with additional 
Alpha channel) and we can 
run Background Remover 

using “Filter->ImageSkill-
>Background Remover 3” 
command. 
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Extracting objects 

1. In order to extract object you must mark some "Object" and "Background’s" colors with green 

and red stripes respectively. This procedure is performed with the tools “Mark object”  and 

“Mark color for erasing” .  

2. After the marking process is completed you only need to click on “Magic Wand”  or  

”Magic Fill”  tool to fulfill the operation of the object keeping and background removing. 
You can adjust the strength of the extraction by setting the relevant parameter of the chosen 
tool. 

3. The color unmixing is done by “Mark defringe zone”  tool. 

4. You can clean received mask by debris removing and holes filling using “Mask Refine”  
tool.  

5. After that you can use “Manual Eraser”  tool to correct final mask if necessary.  

6. You can check the result of the extraction, using preview the extracted object against colored 
matte background, and see the result mask as well.  

 

 
 
 

Mark background and object colors using “Mark object” and “Mark colors for erasing” tools. 
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If you make wrong marks you can erase them by right-click and drag. You can switch between 

these tools by pressing “Ctrl” button. Then choose “Magic Wand” tool for flowers extracting.  

 

Click and drag mouse - you will mark background (red points) and erase it at the same time.  

If you do something wrong you can always revert to the previous operation by pressing Undo 
button. Making right-click and drag you can restore object’s part and mark it as object (green 
points). 
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You can adjust erasing strength by Strength control. Possibly you have to make a few strokes in 

order to succeed.  

Then select Magic Fill tool and click to erase background in the vase. 

 

If necessary, choose Manual Eraser for the final tuning. 
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You can control mask (or see the result in chrome key) using different view option (four buttons 

below “Help” button). 

 

 

When you finish, press OK and return to CS3. 
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Semi-Transparent Object Extracting 

Use this tutorial to learn how to extract a semi-transparent object (girl with flying hair) from a 
textured background. 

 

Source image 

Create layer form background image as described above and run Background Remover. 

Select Mark Object tool and mark object (green curve).  

Select Mark color for erasing tool and mark background (red curve). 

 

 

Select Magic Wand tool and extract portrait.  
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Choose Mark Defringe zone tool and mark girl's hair. 

 

 

 

After marking the process of color unmixing is run. 

You can see that colors are unmixed properly and girl's hair look naturally. 
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You can check the result by placing it against colored matted background. 
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Lace-like Object Extracting 

Use this tutorial to learn how to extract a lace-like object (jewelry, branch of tree etc). 

 

Source image 

Create layer form background image as described above and run Background Remover. 

Select Mark Object tool and mark object (green curve).  

Select Magic Fill tool and mark background (red curve).  Make a mouse click to launch 

extraction. 

 

 

Using Magic Fill tool you can set colors for removing by left mouse click and set colors for 

keeping by right mouse click. Whole image is processed, so you can extract lace-like object by 
marking object and background colors. Pixel’s colors looking like a marked background colors will 
be processed. To all of these pixels some transparency value will be assigned. 

If object and background share some colors, check “Resolve Color” flag. 

You can refine the resulting mask by adjusting the Contrast parameter. 
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You can check the result by placing it against colored matted background. 

 

 

The final mask tuning can be done using Mask Refine tool. 

 



ImageSkill Background Remover: User’s Manual 

 

 ImageSkill Software 2006-2009 24 

FAQ and Troubleshooting 

I can not run Background Remover or Background Remover is 
grey out in graphic host’s effect menu.  

Graphic hosts disable the plug-in if the current image is not suitable for use with Background 
Remover. Image must be in RGB format with 8 or 16 bit/channel and must have a layer (i.e. 
image must have 4 channels: R, G, B, and Alpha). If image has CMYK, LAB, Grayscale or 
something other than RGB format, you have to convert it to RGB. If image has no layer you have 
to create it at first. 

What does happen if my image already has transparent area? 

When you process image with transparent areas, the final transparency in such pixels will be not 
less than source transparency, i.e. plug-in does not increase alpha value in transparent areas. 

How does plug-in process selection? 

The Background Remover affects to selected area only. The unselected area is still unchanged. 
The unselected area is shown with red semi-transparent color in main plug-in window. Plug-in 
deals with the bounding box selection. 

 

 

 

  

 

Image with selection The unselected area is filled by 
semi-transparent red color 

Result of the processing 

 

NOTE:  

If you did not find answer on your questions, write your questions to support@imageskill.com 

or send them to support forum http://forum.imageskill.com 

 

mailto:support@imageskill.com
http://forum.imageskill.com/

	ImageSkill Software
	Background Remover v 3.2
	User’s Manual
	Introduction
	Features at glance
	System Requirements
	Registering ImageSkill Background Remover
	Getting Technical Support
	Examples

	Getting Started
	Installing and uninstalling
	User interface
	A. View
	B. Toolbar


	Working with Background Remover
	Source data
	Change language
	Starting Background Remover
	Extracting objects
	Semi-Transparent Object Extracting
	Lace-like Object Extracting
	I can not run Background Remover or Background Remover is grey out in graphic host’s effect menu.
	What does happen if my image already has transparent area?
	How does plug-in process selection?


